### What it does Checks for usage of `_.filter(_).next()`. ### Why is this bad? Readability, this can be written more concisely as `_.find(_)`. ### Example ``` vec.iter().filter(|x| **x == 0).next(); ``` Use instead: ``` vec.iter().find(|x| **x == 0); ```